re = /src=\"(?P<src>img\/programacao\/[^\"]+)\"/
str = '"<img src="img/programacao/51.jpg" style="width:200px;" /><p>balbalba</p><img src="img/programacao/46.jpg" style="width:200px;" /><p>balbalba</p><img src="/img/finalCinerio.jpg"><p>balbalba</p><img src="img/topo.jpg" />"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end