using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\""'])(?:\\\1|\1\1|(?!\1).)*\1";
string input = @"'value1',""value2 with \' escaped quote','value with '' is here','value4'";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}