re = /([\"'])(?:\\\1|\1\1|(?!\1).)*\1/
str = '\'value1\',"value2 with \\\' escaped quote\',\'value with \'\' is here\',\'value4\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end