const regex = /\s+D\=(?<rdur>\d+\s*?)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s+D\\=(?<rdur>\\d+\\s*?)', '')
const str = ` t=1445878277835222 D=285883
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}