$re = '/\s+D\=(?<rdur>\d+\s*?)/';
$str = ' t=1445878277835222 D=285883
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);