import Foundation
let pattern = #"\s+D\=(?<rdur>\d+\s*?)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
t=1445878277835222 D=285883
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}