package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^#(?:[A-Fa-f0-9]{3}){1,2}$`)
var str = `#0F0F0F
#123
#1234
#ABC456
#1234567`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}