$re = '/^#(?:[A-Fa-f0-9]{3}){1,2}$/m';
$str = '#0F0F0F
#123
#1234
#ABC456
#1234567';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);