import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^hsl[(]\\s*0*(?:[12]?\\d{1,2}|3(?:[0-5]\\d|60))\\s*(?:\\s*,\\s*0*(?:\\d\\d?(?:\\.\\d+)?\\s*%|\\.\\d+\\s*%|100(?:\\.0*)?\\s*%)){2}\\s*[)]$";
final String string = "#0F0F0F\n"
+ "#123\n"
+ "#1234\n"
+ "#ABC456\n"
+ "#1234567\n"
+ "rgb(1,2,3)\n"
+ "rgb(1,2,)\n"
+ "rgb(112233)\n"
+ "rgb(255,249,199)\n"
+ "rgb(256,249,199)\n"
+ "rgb(255,249,199,)\n"
+ "rgb( 100%, 199, 50%)\n"
+ "rgb( 100%, 199%, 50%)\n"
+ "rgb(1,2,3%,.5)\n"
+ "rgba(1,2,3%,0.75)\n"
+ "rgba(1,2,3%,.5)\n"
+ "rgba(1,2,.5)\n"
+ "rgba(1,2,3)\n"
+ "rgba(1,249,100,1)\n"
+ "rgba(1,249,100,1.0)\n"
+ "rgba(1,249,100,1.1)\n"
+ "rgba(255,256,255,1)\n"
+ "rgba(1,249.5,100%,1)\n"
+ "rgba(1,249.5,101%,1)\n"
+ "hsl(360,2%,100%)\n"
+ "hsl(361,2%,100%)\n"
+ "hsl(,2%,100%)\n"
+ "hsl(360,2%,)\n"
+ "hsl(360,2%,0100.00%)\n"
+ "hsl(360,2%,101%)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}