import Foundation
let pattern = #"^hsl[(]\s*0*(?:[12]?\d{1,2}|3(?:[0-5]\d|60))\s*(?:\s*,\s*0*(?:\d\d?(?:\.\d+)?\s*%|\.\d+\s*%|100(?:\.0*)?\s*%)){2}\s*[)]$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
#0F0F0F
#123
#1234
#ABC456
#1234567
rgb(1,2,3)
rgb(1,2,)
rgb(112233)
rgb(255,249,199)
rgb(256,249,199)
rgb(255,249,199,)
rgb( 100%, 199, 50%)
rgb( 100%, 199%, 50%)
rgb(1,2,3%,.5)
rgba(1,2,3%,0.75)
rgba(1,2,3%,.5)
rgba(1,2,.5)
rgba(1,2,3)
rgba(1,249,100,1)
rgba(1,249,100,1.0)
rgba(1,249,100,1.1)
rgba(255,256,255,1)
rgba(1,249.5,100%,1)
rgba(1,249.5,101%,1)
hsl(360,2%,100%)
hsl(361,2%,100%)
hsl(,2%,100%)
hsl(360,2%,)
hsl(360,2%,0100.00%)
hsl(360,2%,101%)
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)