# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^hsl[(]\s*0*(?:[12]?\d{1,2}|3(?:[0-5]\d|60))\s*(?:\s*,\s*0*(?:\d\d?(?:\.\d+)?\s*%|\.\d+\s*%|100(?:\.0*)?\s*%)){2}\s*[)]$"
test_str = ("#0F0F0F\n"
"#123\n"
"#1234\n"
"#ABC456\n"
"#1234567\n"
"rgb(1,2,3)\n"
"rgb(1,2,)\n"
"rgb(112233)\n"
"rgb(255,249,199)\n"
"rgb(256,249,199)\n"
"rgb(255,249,199,)\n"
"rgb( 100%, 199, 50%)\n"
"rgb( 100%, 199%, 50%)\n"
"rgb(1,2,3%,.5)\n"
"rgba(1,2,3%,0.75)\n"
"rgba(1,2,3%,.5)\n"
"rgba(1,2,.5)\n"
"rgba(1,2,3)\n"
"rgba(1,249,100,1)\n"
"rgba(1,249,100,1.0)\n"
"rgba(1,249,100,1.1)\n"
"rgba(255,256,255,1)\n"
"rgba(1,249.5,100%,1)\n"
"rgba(1,249.5,101%,1)\n"
"hsl(360,2%,100%)\n"
"hsl(361,2%,100%)\n"
"hsl(,2%,100%)\n"
"hsl(360,2%,)\n"
"hsl(360,2%,0100.00%)\n"
"hsl(360,2%,101%)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.