#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*\.\.)[a-zA-Z0-9_'-](?:[a-zA-Z0-9_'.-]{0,62}[a-zA-Z0-9_'-])?$"
Local $sString = "." & @CRLF & _
".." & @CRLF & _
".a." & @CRLF & _
"a.a" & @CRLF & _
"abc123_'-.b" & @CRLF & _
"1234567890123456789012345678901234567890123456789012345678901234" & @CRLF & _
"12345678901234567890123456789012345678901234567890123456789012345"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")