$re = '/^(?!.*\.\.)[a-zA-Z0-9_\'-](?:[a-zA-Z0-9_\'.-]{0,62}[a-zA-Z0-9_\'-])?$/m';
$str = '.
..
.a.
a.a
abc123_\'-.b
1234567890123456789012345678901234567890123456789012345678901234
12345678901234567890123456789012345678901234567890123456789012345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);