const regex = /^(?!.*\.\.)[a-zA-Z0-9_'-](?:[a-zA-Z0-9_'.-]{0,62}[a-zA-Z0-9_'-])?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*\\.\\.)[a-zA-Z0-9_\'-](?:[a-zA-Z0-9_\'.-]{0,62}[a-zA-Z0-9_\'-])?$', 'gm')
const str = `.
..
.a.
a.a
abc123_'-.b
1234567890123456789012345678901234567890123456789012345678901234
12345678901234567890123456789012345678901234567890123456789012345`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}