#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[\w-+]+(?:\.[\w-]+)*@[\w-]+\.[\w'\-\s,#\\]*\.?(?:[A-Za-z]{2,3})$"
Local $sString = "steve@gmail.com.com.com" & @CRLF & _
"steve@gmail.com.nz" & @CRLF & _
"steve@gmail.com.co.nz" & @CRLF & _
"steve@gmail.comfooobar.co" & @CRLF & _
"steve@gmail.com" & @CRLF & _
"steve.foo@bar.baz"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")