$re = '/^[\w-+]+(?:\.[\w-]+)*@[\w-]+\.[\w\'\-\s,#\\\\]*\.?(?:[A-Za-z]{2,3})$/m';
$str = 'steve@gmail.com.com.com
steve@gmail.com.nz
steve@gmail.com.co.nz
steve@gmail.comfooobar.co
steve@gmail.com
steve.foo@bar.baz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);