package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\w-+]+(?:\.[\w-]+)*@[\w-]+\.[\w'\-\s,#\\]*\.?(?:[A-Za-z]{2,3})$`)
var str = `steve@gmail.com.com.com
steve@gmail.com.nz
steve@gmail.com.co.nz
steve@gmail.comfooobar.co
steve@gmail.com
steve.foo@bar.baz`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}