const regex = /^[\p{Arabic}\s\p{N}]+$/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\p{Arabic}\\s\\p{N}]+$', 'gmu')
const str = `تجريب 123 تجريب 123
123 abc 456`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}