$re = '/^[\p{Arabic}\s\p{N}]+$/mu';
$str = 'تجريب 123 تجريب 123
123 abc 456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);