#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\/(.*?)\/(?:(?<!\/_)(price|name)(?!_\/))?_?(?:(?<!\/_)(asc|desc)(?!_\/))?_?(?:(?<!\/_)(30|40)(?!_\/))?_?(?:(?<!\/_)(list)(?!_\/))?\/$"
Local $sString = "/some_url/price_desc_30_list/" & @CRLF & _
"/some_url/_30/" & @CRLF & _
"/some_url/30/" & @CRLF & _
"/some_url/price_30_list/" & @CRLF & _
"/some_url/price_desc_list/" & @CRLF & _
"/some_url/price_desc_30/" & @CRLF & _
"/some_url/desc_30_list_/" & @CRLF & _
"/some_url/desc_30_/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")