const regex = /^\/(.*?)\/(?:(?<!\/_)(price|name)(?!_\/))?_?(?:(?<!\/_)(asc|desc)(?!_\/))?_?(?:(?<!\/_)(30|40)(?!_\/))?_?(?:(?<!\/_)(list)(?!_\/))?\/$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\\/(.*?)\\\/(?:(?<!\\\/_)(price|name)(?!_\\\/))?_?(?:(?<!\\\/_)(asc|desc)(?!_\\\/))?_?(?:(?<!\\\/_)(30|40)(?!_\\\/))?_?(?:(?<!\\\/_)(list)(?!_\\\/))?\\\/$', 'gm')
const str = `/some_url/price_desc_30_list/
/some_url/_30/
/some_url/30/
/some_url/price_30_list/
/some_url/price_desc_list/
/some_url/price_desc_30/
/some_url/desc_30_list_/
/some_url/desc_30_/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}