$re = '/^\/(.*?)\/(?:(?<!\/_)(price|name)(?!_\/))?_?(?:(?<!\/_)(asc|desc)(?!_\/))?_?(?:(?<!\/_)(30|40)(?!_\/))?_?(?:(?<!\/_)(list)(?!_\/))?\/$/m';
$str = '/some_url/price_desc_30_list/
/some_url/_30/
/some_url/30/
/some_url/price_30_list/
/some_url/price_desc_list/
/some_url/price_desc_30/
/some_url/desc_30_list_/
/some_url/desc_30_/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);