const regex = /[“â€\u0141-\u017A]/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[“â€\\u0141-\\u017A]', 'gmi')
const str = `“windows-1252 quotesâ€`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);