const regex = /^[^.]+\d[ab][^.]*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^.]+\\d[ab][^.]*', 'gm')
const str = `test02a-d.test.example.net
test02b-d.test.example.net
test03a.test.example.net
test03b.test.example.net
test04-d.test.example.net
test05.test.example.net
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}