use strict;
my $str = 'test02a-d.test.example.net
test02b-d.test.example.net
test03a.test.example.net
test03b.test.example.net
test04-d.test.example.net
test05.test.example.net
';
my $regex = qr/^[^.]+\d[ab][^.]*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}