import re
regex = re.compile(r"^[^.]+\d[ab][^.]*", flags=re.MULTILINE)
test_str = ("test02a-d.test.example.net\n"
"test02b-d.test.example.net\n"
"test03a.test.example.net\n"
"test03b.test.example.net\n"
"test04-d.test.example.net\n"
"test05.test.example.net\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")