#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[<]"
Local $sString = "<h3>This is sample HTML Coding</h3>" & @CRLF & _
"" & @CRLF & _
"<pre><code>" & @CRLF & _
" <html>" & @CRLF & _
" <body>" & @CRLF & _
" Hello World" & @CRLF & _
" </body>" & @CRLF & _
" </html>" & @CRLF & _
"</code></pre>" & @CRLF & _
"" & @CRLF & _
"<h3>This is another sample HTML Coding</h3>" & @CRLF & _
"" & @CRLF & _
"<pre><code>" & @CRLF & _
" <html>" & @CRLF & _
" <body>" & @CRLF & _
" Another Hello World" & @CRLF & _
" </body>" & @CRLF & _
" </html>" & @CRLF & _
"</code></pre>" & @CRLF & _
"" & @CRLF & _
" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")