import re
regex = re.compile(r"[<]")
test_str = ("<h3>This is sample HTML Coding</h3>\n\n"
"<pre><code>\n"
" <html>\n"
" <body>\n"
" Hello World\n"
" </body>\n"
" </html>\n"
"</code></pre>\n\n"
"<h3>This is another sample HTML Coding</h3>\n\n"
"<pre><code>\n"
" <html>\n"
" <body>\n"
" Another Hello World\n"
" </body>\n"
" </html>\n"
"</code></pre>\n\n"
" ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")