re = /[<]/
str = '<h3>This is sample HTML Coding</h3>
<pre><code>
<html>
<body>
Hello World
</body>
</html>
</code></pre>
<h3>This is another sample HTML Coding</h3>
<pre><code>
<html>
<body>
Another Hello World
</body>
</html>
</code></pre>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end