import re
regex = re.compile(r"^([^\n]*TenGigE[^\n]*)(?:(?!TenGigE|carrier-delay).)*([^\n]*carrier-delay[^\n]*)", flags=re.DOTALL | re.MULTILINE)
test_str = ("interface TenGigE0/0/0/8\n"
" bundle id 221 mode active\n"
" lacp period short\n"
" lacp period short receive 100\n"
" lacp period short transmit 100\n"
" carrier-delay up 100 down 100\n\n"
"interface TenGigE0/0/0/7\n\n\n\n"
"shutdown\n\n"
"!\n\n"
"interface TenGigE0/0/0/8\n\n\n\n"
" bundle id 221 mode active\n\n"
" lacp period short\n\n"
" lacp period short receive 100\n\n"
" lacp period short transmit 100\n\n"
" carrier-delay up 100 down 100\n\n"
" load-interval 30\n\n"
" frequency synchronization\n\n"
" !\n\n"
" transceiver permit pid all\n\n"
"!\n\n"
"interface TenGigE0/0/0/9\n\n\n\n"
" mtu 9216\n\n"
" frequency synchronization\n\n"
" !\n\n"
" transceiver permit pid all\n\n"
"!\n\n"
"interface TenGigE0/0/0/10\n\n\n\n"
" bundle id 237 mode active\n\n"
" lacp period short\n\n"
" lacp period short receive 100\n\n"
" lacp period short transmit 100\n\n"
" carrier-delay up 120000 down 150\n\n"
" load-interval 30\n\n"
" frequency synchronization")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")