re = /^([^\n]*TenGigE[^\n]*)(?:(?!TenGigE|carrier-delay).)*([^\n]*carrier-delay[^\n]*)/m
str = 'interface TenGigE0/0/0/8
bundle id 221 mode active
lacp period short
lacp period short receive 100
lacp period short transmit 100
carrier-delay up 100 down 100
interface TenGigE0/0/0/7
shutdown
!
interface TenGigE0/0/0/8
bundle id 221 mode active
lacp period short
lacp period short receive 100
lacp period short transmit 100
carrier-delay up 100 down 100
load-interval 30
frequency synchronization
!
transceiver permit pid all
!
interface TenGigE0/0/0/9
mtu 9216
frequency synchronization
!
transceiver permit pid all
!
interface TenGigE0/0/0/10
bundle id 237 mode active
lacp period short
lacp period short receive 100
lacp period short transmit 100
carrier-delay up 120000 down 150
load-interval 30
frequency synchronization'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end