import Foundation
let pattern = #"^([^\n]*TenGigE[^\n]*)(?:(?!TenGigE|carrier-delay).)*([^\n]*carrier-delay[^\n]*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
interface TenGigE0/0/0/8
bundle id 221 mode active
lacp period short
lacp period short receive 100
lacp period short transmit 100
carrier-delay up 100 down 100
interface TenGigE0/0/0/7
shutdown
!
interface TenGigE0/0/0/8
bundle id 221 mode active
lacp period short
lacp period short receive 100
lacp period short transmit 100
carrier-delay up 100 down 100
load-interval 30
frequency synchronization
!
transceiver permit pid all
!
interface TenGigE0/0/0/9
mtu 9216
frequency synchronization
!
transceiver permit pid all
!
interface TenGigE0/0/0/10
bundle id 237 mode active
lacp period short
lacp period short receive 100
lacp period short transmit 100
carrier-delay up 120000 down 150
load-interval 30
frequency synchronization
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)