using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S)(\d+)(?:-(\d+))?";
string input = @"L A 16-25MPH
LMT ACC 6-10
6 OVER
LIMITED ACCESS SPEED I-75";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}