re = /(?<!\S)(\d+)(?:-(\d+))?/
str = 'L A 16-25MPH
LMT ACC 6-10
6 OVER
LIMITED ACCESS SPEED I-75'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end