const regex = new RegExp('(?<!\\S)(\\d+)(?:-(\\d+))?', 'g')
const str = `L A 16-25MPH
LMT ACC 6-10
6 OVER
LIMITED ACCESS SPEED I-75`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}