import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(?!\\/?a(?=>|\\s.*>))\\/?.*?>([^$]+?)<(?!\\/?a(?=>|\\s.*>))\\/?.*?>";
final String string = "Oi, fulano. Acesse esse <a href=\"link\">link</a> e digite <span>Meu nome é <a href=\"teste\">teste</a></span>. Depois disso, vá até tal lugar e então cole o código <header> <div class=\"title text-center\"><h1>Testando</h1></div> </header>.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}