const regex = /<(?!\/?a(?=>|\s.*>))\/?.*?>([^$]+?)<(?!\/?a(?=>|\s.*>))\/?.*?>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(?!\\\/?a(?=>|\\s.*>))\\\/?.*?>([^$]+?)<(?!\\\/?a(?=>|\\s.*>))\\\/?.*?>', 'gm')
const str = `Oi, fulano. Acesse esse <a href="link">link</a> e digite <span>Meu nome é <a href="teste">teste</a></span>. Depois disso, vá até tal lugar e então cole o código <header> <div class="title text-center"><h1>Testando</h1></div> </header>.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}