$re = '/<(?!\/?a(?=>|\s.*>))\/?.*?>([^$]+?)<(?!\/?a(?=>|\s.*>))\/?.*?>/m';
$str = 'Oi, fulano. Acesse esse <a href="link">link</a> e digite <span>Meu nome é <a href="teste">teste</a></span>. Depois disso, vá até tal lugar e então cole o código <header> <div class="title text-center"><h1>Testando</h1></div> </header>.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);