package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?:\B#\s?)((\S+\s+\S+\s+\S+)|(.*?#))`)
var str = `#test1 test2 #test3 test4 test5 #test6 test7 test8 test9 test10#test11 test12 #test13 test14 test15 test16 test17`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}