using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:
""([^""\\]*(?:\\.[^""\\]*)*)""
|
[\w-]+(?:=""?[^""\\]*(?:\\.[^""\\]*)*""?)?
)
";
string input = @"@(""hello, world"" bold italic font-size=""15"")";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}