package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:
"([^"\\]*(?:\\.[^"\\]*)*)"
|
[\w-]+(?:="?[^"\\]*(?:\\.[^"\\]*)*"?)?
)
`)
var str = `@("hello, world" bold italic font-size="15")`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}