import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[IMG\\].+?\\[\\/IMG\\]";
final String string = "[ IMG ] http://test.test/test.jpg [ /IMG] sdfsgeg\n"
+ "ewye [IMG]http://test.test/test.jpg [/ IMG]ertw\n"
+ "rtwertewt [IMG]http://test.test/test.jpg[/IMG]sdfweqw\n\n"
+ "erqwerwq [ IMG ] http://test.test/test.jpg[ / IMG ]jnljlkjljlkj";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}