re = /\[IMG\].+?\[\/IMG\]/
str = '[ IMG ] http://test.test/test.jpg [ /IMG] sdfsgeg
ewye [IMG]http://test.test/test.jpg [/ IMG]ertw
rtwertewt [IMG]http://test.test/test.jpg[/IMG]sdfweqw
erqwerwq [ IMG ] http://test.test/test.jpg[ / IMG ]jnljlkjljlkj'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end