const regex = /\[IMG\].+?\[\/IMG\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[IMG\\].+?\\[\\\/IMG\\]', 'g')
const str = `[ IMG ] http://test.test/test.jpg [ /IMG] sdfsgeg
ewye [IMG]http://test.test/test.jpg [/ IMG]ertw
rtwertewt [IMG]http://test.test/test.jpg[/IMG]sdfweqw
erqwerwq [ IMG ] http://test.test/test.jpg[ / IMG ]jnljlkjljlkj`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}