using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"the (?>big|small|biggest) (cat|dog|bird)";
string input = @"the big dog
the small bird
the biggest dog
the small cat";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}