re = /the (?>big|small|biggest) (cat|dog|bird)/m
str = 'the big dog
the small bird
the biggest dog
the small cat'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end