import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "BBB((?:(?!BBB).)*?)EEE";
final String string = "BBB foo BBB bar EEE\n\n"
+ " BBB bar EEE baz EEE\n\n"
+ "BBB foo BBB bar EEE baz EEE\n\n"
+ "BBBB EEEE\n"
+ "BBBBB EEEE\n"
+ "BBBBBB EEEE\n"
+ "BBBB EEEEE\n"
+ "BBBBB EEEEE\n"
+ "BBBBBB EEEEE\n"
+ "BBBB EEEEEE\n"
+ "BBBBB EEEEEE\n"
+ "BBBBBB EEEEEE";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}