import re
regex = re.compile(r"BBB((?:(?!BBB).)*?)EEE", flags=re.MULTILINE)
test_str = ("BBB foo BBB bar EEE\n\n"
" BBB bar EEE baz EEE\n\n"
"BBB foo BBB bar EEE baz EEE\n\n"
"BBBB EEEE\n"
"BBBBB EEEE\n"
"BBBBBB EEEE\n"
"BBBB EEEEE\n"
"BBBBB EEEEE\n"
"BBBBBB EEEEE\n"
"BBBB EEEEEE\n"
"BBBBB EEEEEE\n"
"BBBBBB EEEEEE")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")