package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:.*?(just a simple)){3}`)
var str = `this is just a simple text. this is just a simple text. this is just a simple text. this is just a simple text. How are you man today. I Have been working on this.`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}