re = /(?:.*?(just a simple)){3}/
str = 'this is just a simple text. this is just a simple text. this is just a simple text. this is just a simple text. How are you man today. I Have been working on this.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end